Translatehtml requires beautifulsoup4==4.9.3 but you'll have beautifulsoup4 4.11.2 which is incompatible

Hi and thanks for taking care of my problem

I got the above error message ( translatehtml 1.5.2) while running the installation script for Unbutu 20.04 which resulted in the installation of beautifulsoup4 4.11.2
I don’t know what is the best way to remedy to this error.

1 Like

It looks like translate-html depends on beautifulsoup4==4.9.3 and argos-translate-files has beautifulsoup4>=4.9.3.

Maybe you already had a version of Beautiful Soup installed? You could try pip uninstall beautifulsoup4 or deleting the virtual environment and then installing again.