Self-hosting via docker, file translations don't work

Using:

image: libretranslate/libretranslate:latest

translation works fine but file translations give this error:

Could not build url for endpoint 'download_file' with values ['filename']. Did you mean 'Main app.download_file' instead?

I tried with a .pptx and a .docx file.

Any ideas? Any more Info I can share?

Also, trying file translation on the demo: LibreTranslate - Free and Open Source Machine Translation API

it seems to be hanging:

1 Like

P.S. after a while the demo works but my self-hosted instance still fails.

Could somebody please verify the file translations on their self-hosted instance, so I know if this is a bug I should report?

after switching to the latest tag:

image: libretranslate/libretranslate:latest

I can upload a file for translation, and I am provided a download link but the download button doesn’t work. The web developer console says:

Mixed Content: The site at 'https://translate.mydomain.tld/' was loaded over a secure connection, but the file at 'https://translate.mydomain.tld/download_file/1a2f43b7-496c-4eb9-a3f7-dcd589afde07.Consultant_Job_Spec_de.docx' was redirected through an insecure connection. This file should be served over HTTPS. This download has been blocked. See https://blog.chromium.org/2020/02/protecting-users-from-insecure.html for more details.

I am running LT behind a reverse proxy. Could LT to maybe leave out the scheme when creating the download link or maybe figure out which scheme was used to access LT and then use the same for the download button?

2 Likes

There is an option to enable SSL:

–ssl Whether to enable SSL False LT_SSL

Not sure if this will actually do what you want though I haven’t enabled it myself since I don’t need file translations.

1 Like