LibreTranslate server frontend, SSL, Apache only

I have it up and running, and API backend -

Have ProxyPass and ProxyPassReverse set to

It all seemed to work fine. And mainly does. But I just noticed…

The link to API Docs does not

Yet oddly the link to Javascript license does?

Something with the Swagger I need to adjust? It goes from GET docs to GET /docs/, and stops. On libretranslate site it then goes from /docs/ to fetching swagger scripts.

I suppose I could skip figuring it out and adjust the template to link to libretranslate/docs …

1 Like

Dangit. I assume one of the training init scripts. Somehow everything stopped working, and I found nginx was running and listening all over the place. Killed it. Tried apt remove nginx and it said it wasn’t installed. So I just deleted the binary.

But I guess I have to start back a bit. Now this works:

But this doesn’t anymore:

Original note… API Docs still doesn’t work even on while Javascript license does… So that still stands too :slight_smile: