Istallationproblem on MX Xfce

Hi folks,
on a Dell Optiplex 740 with a MX (Xfce)

I have absolutely no idea about python, so I just followed the steps given.
pip install was not possible so I listened to the advice to perform this process with pipx, which apparently worked after expiration.


I understood it to mean that the symlinks were wrong and added them,
after I changed the names of the original files…
apparently this was not the case to go… so I removed the two files and ran the installation process again with --force --verbose
and it was indeed as expected that the symlinks were then added again,
but it doesn’t change the result…
if I start the process by argos-translate-gui
it remains with “Invalid machine command”

then i tested both packages with pipx install argostranslate
and pipx install argostranslategui again
but the packages are properly installed according to the console output

For the sake of completeness…
an upgrade-all did not change the version
I then changed this installation process to an another computer with the same system but KDE(Plasma5) interface where it worked

if anyone has any helpful ideas, it would be nice to read them
[this was translated by deepl]

I’m not sure what the problem is. I recommend installing the Python library in a virtual environment.

sudo apt install -y python3-venv
virtualenv myenv
source myenv/bin/activate
pip install argostranslategui

thanks for the reply
that’s exactly what pipx does for you,
As already noted in the main post, pip doesn’t work
see screen

and as you can see on this screen,
the installation is ok,
everything is obviously in the correct place, with the correct link, but it remains with “Invalid machine command”

I just remembered something else and so I tried to start argos-translate-gui with pipx
using “pipx run argos-translate-gui”,
but it seems to access the incompatible pip and can’t recognize the installation.

The text in the log file is 100% the same…

Now I really have no more ideas

Hello again

I have now run through the entire process from scratch and have omitted the gui.
The problem starts with argostranslate.
argospm (responsible for the language pack installation) works perfectly.
So argos-translate … called via the console gives the same error message as calling argos-translate-gui (which is logical)

(pipx install argostranslate
calling argos-translate … remains with “Invalid machine command”

argospm install translate-en_de
argospm install translate-de_en
to download

.local/share/argos-translate/packages/ ← here they are present)