Docx and odt returned untranslated


I have installed Libretranslate using LibreTranslate-init and configured the nginx proxy according to the docs on Github. It works great with text input and for instance txt files.

However with files like docx and odt the uploaded file gets returned without being translated. No errors in the logs or webconsole, I tried with debug=True. I do see the files in /tmp, both the original and what should be translated file.

Has anyone else run into this issue, ideas on how to solve this? Many thanks for any help on this in advance.

1 Like

This is probably an issue with Argos Translate Files but I’m not sure what.

I just did this test and it worked:

  1. Create and save an .odt file using LibreOffice (only a few sentences so the translation doesn’t time out)
  2. Translate en->zh on
  3. Verify that the translation was performed

Could you share with us the files ?

Thanks, I tested the file, any language I tried it returns the file unchanged in english.