Translation gives <blank>

I just installed the LIbreTranslate API play around with APIs. However it seems I’m geting a wrong translation, please see below screenshot. “Hello World” results in a long list of tags from en to es. I tried Googling but couldn’t find a similar issue. I noticed that libretranslation server downloaded multiple dictionaries when I first ran it. Is this an issue with the dictionaries? If so, how do I update them? Thanks in advance

Mm, so strange! The app seems to work OK on

You can install the latest models by running the script (if you used Python/PIP to install it).

Thanks for your reply. I did install it using pip3, but I don’t really know anything about Python. How do I run

Just invoke python from a shell.

I get an error of No such file or directory. I tried running argos-translate directly, and it gives me the same issue. I guess the problem is with that:

Edit: I downloaded and tried running the Mac OS and unfortunately it too doesn’t work on my system. There don’t seem to be any
languages to choose from the drop down and when I went to Manage packages > Download package and pressed the download button, the app crashed.

Crash report:

Strange. Maybe @argosopentech have an idea ?

This is strange, maybe related to this:

Mac app is a different issue, I think I just pushed a fix to. The Mac app runs on a separate package index to do seq2seq sentence boundary detection that had gotten out of date.